Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005




НазваниеМетодические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005
страница1/6
Дата конвертации31.12.2012
Размер0.63 Mb.
ТипМетодические рекомендации
  1   2   3   4   5   6


ФЕДЕРАЛЬНОЕ АГЕНТСТВО ПО ОБРАЗОВАНИЮ РФ


Государственное образовательное учреждение

высшего профессионального образования

«Алтайский государственный технический университет

имени И.И. Ползунова»


Бийский технологический институт (филиал)


В.И. Попов, Н.С. Атрощенко


ПРОЕКТИРОВАНИЕ ИНФОРМАЦИОННЫХ СИСТЕМ

В СРЕДЕ RATIONAL ROSE


Методические рекомендации по выполнению лабораторных работ

для студентов специальностей 351400 «Прикладная информатика
(в экономике)», 071900 «Информационные системы и технологии»


Бийск 2005

УДК 681.3.06


Попов В.И., Атрощенко Н.С. Проектирование информационных систем в среде Rational Rose: Методические рекомендации к лабораторным работам для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии».


Алт. гос. тех. ун-т, БТИ.  Бийск.

Изд-во Алт. гос. тех. ун-та, 2005.  70 с.


В методических рекомендациях приведены сведения о программной среде Rational Rose, изложены основные приемы проектирования информационной системы, а также рассматривается также пример проектирования информационной системы.

Рекомендации предназначены для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» по курсу «Проектирование информационных систем».


Рассмотрены и одобрены

на заседании кафедры ИУС.

Протокол №12 от 18.04.2005 г.


Рецензент: к.ф-м.н, доцент кафедры МСИА Пальчиков А.В.


© Попов В.И., Атрощенко Н.С., 2005

© БТИ АлтГТУ, 2005

ВВЕДЕНИЕ


Появление на рынке программных продуктов первых CASE-средств (Computer Aided Software Engineering) ознаменовало новый этап развития программной инженерии, характерными особенностями которого являются существенное сокращение сроков разработки программных проектов, реализация проектов группой программистов и ориентация на визуальные средства специфицирования компонентов программного обеспечения.

Термин «CASE» используется в настоящее время в весьма широком смысле. Первоначальное значение термина CASE, ограниченное вопросами автоматизации разработки только лишь программного обеспечения (ПО), в настоящее время приобрело новый смысл, охватывающий процесс разработки сложных информационных систем (ИС) в целом. Теперь под термином CASE-средства понимаются програм-мные средства, поддерживающие процессы создания и сопровождения ИС, включая анализ и формулировку требований, проектирование прикладного ПО (приложений) и баз данных, генерацию кода, тестирование, документирование, обеспечение качества, конфигурационное управление и управление проектом, а также другие процессы.
CASE-средства вместе с системным ПО и техническими средствами образуют полную среду разработки ИС.

Классической областью применения этих средств стали приложения баз данных, особенно те из них, которые требовали серьезных усилий при разработке своих концептуальных схем. Поддержка возможности автоматической генерации программного кода на основе предварительно разработанной концептуальной схемы оказалась настолько конструктивной, что стимулировала появление более двух десятков CASE-средств различных фирм [4].

Начальный этап развития CASE-технологий характеризовался тем, что разные фирмы предлагали свои собственные средства визуального представления концептуальных средств. Зачастую выбор того или иного CASE-средства разработчиками определялся простотой нотации поддерживаемого средством языка представления схем и диаграмм. Появление первых стандартов в этой области лишь на какое-то время стабилизировало ситуацию. Однако острейшая конкуренция среди фирм-производителей программного обеспечения требовала от CASE-средств реализации объектно-ориентированной технологии разработки программ и поддержки широкого диапазона языков программирования и конкретных баз данных.

Компания Rational Software (c ноября 2003 года подразделение IBM) является лидирующей в области создания методологий и программных решений, ориентированных на программистов, аналитиков, тестировщиков. В итоге все решения были собраны воедино. Так появился RUP  Rational Unified Process  методологическая энциклопедия, в которой описаны все шаги, необходимые для создания ИС.

Особое место в RUP занимают проектирование и конфигурационное управление. Особо выделяются они потому, что те два инструмента, которые поддерживаются на данных этапах (Rational Rose и Rational ClearCase), используются на протяжении всего жизненного цикла разработки программного обеспечения [2].


1 ПРОГРАММА RATIONAL ROSE


1.1 Общая характеристика CASE-средства Rational Rose


CASE-средство Rational Rose со времени своего появления претерпело серьезную эволюцию и превратилось в современное и мощное средство анализа, моделирования и разработки ИС. Именно в Rational Rose язык UML стал базовой технологией визуализации и разработки.

В рамках Rational Rose существуют различные программные инструментарии, отличающиеся между собой диапазоном реализованных возможностей.

Базовым средством в настоящее время остается Rational Rose, которое существует в четырех основных модификациях:

  • Rational Rose Enterprise Edition;

  • Rational Rose Professional Edition;

  • Rational Rose Modeler Edition;

  • Rational Rose для UNIX.

Наиболее полными возможностями обладает первая из указанных модификаций данного средства. Из этих возможностей можно отметить: реализацию UML, генерацию кодов на различных языках программирования (Java, C++, VisualBasic, PowerBuilder), обратную генерацию диаграмм (реинжиниринг) на основе программного кода и выпуск проектной документации [3].

Rational Rose позволяет генерировать программный код стандарта MS Visual C++, обеспечивает документирование проекта в формате HTML для Web-публикации и поддерживает интеграцию с другими инструментариями объектно-ориентированной разработки программ, базами данных и с компонентами MS Office.

Возможны практически все современные достижения в области информационных технологий:

  • интеграция с MS Visual Studio, что включает в себя поддержку на уровне прямой и обратной генерации кодов и диаграмм VB, Visual C++, Visual J++ (ATL-Microsoft Active Template Library, Web-Classes, DHTML, Data Connections);

  • непосредственная работа (инжиниринг и реинжиниринг) с исполняемыми модулями и библиотеками форматов EXE, DLL, TLB, OCX;

  • поддержка технологий MTS (Microsoft Transaction Server) и ADO (ActiveX Data Objects) на уровне шаблонов и исходного кода, а также элементов стратегической технологии Microsoft  СОМ+ (DCOM);

  • полная поддержка CORBA 2.2, включая реализацию технологии компонентной разработки приложений CBD (Component-Based Development), языка определения интерфейса IDL (Interface Definition Language) и языка определения данных DDL (Data Definition Language);

  • полная поддержка среды разработки Java-приложений JDK 1.2, включая прямую и обратную генерацию классов Java формата JAR, а также работу с файлами форматов CAB и ZIP.

Широкие возможности Rational Rose позволяют:

  • проектировать системы любой сложности;

  • давать развернутое представление о проекте в сочетании со средствами документирования (SoDA);

  • проводить кодогенерацию;

  • проводить обратное проектирование имеющихся систем.

Также Rational Rose:

    • имеет открытый для дополнений интерфейс;

    • интегрируется со средствами разработки (Visual Studio);

    • поддерживает язык UML;

    • имеет средства автоматического контроля, в том числе проверки соответствия двух моделей;

    • удобный для пользователя графический интерфейс;

    • многоплатформенность;

    • интегрируемость с другими инструментальными средствами, поддерживающими жизненный цикл программных систем, в том числе со средством управления требованиями (Requisite Pro), со средствами тестирования (SQA Suite, Performance Studio), со средствами конфигурационного управления (ClearCase, PVCS) [5].


1.2 Использование UML в проектировании ПО


Являясь объектно-ориентированным инструментом моделирования, Rose базируется на UML (Universal Modeling Language)  универсальном языке моделирования, который был разработан компанией Rational именно с целью создания наиболее оптимального и универсального языка для описания как предметной области, так и конкретной задачи в программировании. Программа базируется всего на семи диаграммах, которые в зависимости от ситуации способны описывать различные действия:

  • Activity diagram (диаграммы описаний технологий, процессов, функций);

  • Use case diagram (диаграммы функций);

  • Class diagram (диаграммы классов);

  • State diagram (диаграммы состояний);

  • Sequence diagram (диаграммы последовательностей действий);

  • Collaboration diagram (диаграммы взаимодействий);

  • Component diagram (диаграммы компонент);

  • Deployment diagram (диаграммы топологии).

Процесс создания программных систем (ПС) по методологии разработки программных систем Rational Unified Process фирмы Rational Software Corporation включает следующие шесть этапов:

  1. моделирование предметной области (Business Modeling);

  2. определение требований к системе (Requirements);

  3. анализ и проектирование (Analysis & Design);

  4. разработку (Implementation);

  5. тестирование (Test);

  6. внедрение (Deployment).

Моделирование бизнес-процессов для описания предметной области, для которой разрабатывается программная система, производится собственно на этапе разработки ПС, моделирование предметной области (Business Modeling)  с использованием диаграмм деятельности (activity diagram) CASE-средства Rational Rose.

Технология UML, одобренная консорциумом Object Management Group, является мощным средством описания бизнес-процессов и представления их в той форме, которая устраивает как разработчиков, так и пользователей. В данном обзоре будет показано, каким образом с помощью технологии UML можно ускорить цикл разработки и повысить надежность приложений.

Принятые графические обозначения полностью описывают шаги, необходимые для завершения того или иного действия.

Процессы складываются в ясные логические последовательности, которые делают блок-схемы прекрасным средством представления
деловых задач и упрощают кодирование приложений [3].


1.3 Интерфейс программы Rational Rose


В CASE-средстве Rational Rose реализованы общепринятые стандарты на рабочий интерфейс программы, подобно известным средам визуального программирования. После установки Rational Rose на компьютер пользователя запуск этой программы в среде MS Windows приводит к появлению на экране рабочего интерфейса (рисунок 1.1).





Рисунок 1.1 – Общий вид рабочего интерфейса программы
Rational Rose


Рабочий интерфейс Rational Rose состоит из различных элементов, основными из которых являются:

  • главное меню программы;

  • окно диаграммы;

  • стандартная панель инструментов;

  • окно документации;

  • окно браузера;

  • окно журнала;

  • специальная панель инструментов.

Рассмотрим кратко назначение и основные функции каждого из этих элементов.

1.3.1 Главное меню программы


Главное меню программы выполнено в общепринятом стандарте и имеет вид, как на рисунке 1.2.

Отдельные пункты меню, назначение которых понятно из их названий, объединяют сходные операции, относящиеся ко всему проекту в целом. Некоторые из пунктов меню содержат хорошо знакомые функции (открытие проекта, вывод на печать диаграмм, копирование в буфер и вставка из буфера различных элементов диаграмм). Другие настолько специфичны, что могут потребовать дополнительных усилий на изучение (опции генерации программного кода, проверка согласованности моделей, подключение дополнительных модулей).





Рисунок 1.2 – Внешний вид главного меню программы


1.3.2 Стандартная панель инструментов


Стандартная панель инструментов располагается ниже главного меню программы и имеет вид, представленный на рисунке 1.3. Некоторые из инструментов недоступны (новый проект не имеет никаких элементов). Стандартная панель инструментов обеспечивает быстрый доступ к тем командам меню, которые выполняются разработчиками наиболее часто.





Рисунок 1.3 – Внешний вид стандартной панели инструментов


Пользователь может настроить внешний вид этой панели по своему усмотрению. Для этого необходимо выбрать пункт меню
Tools -> Options (Инструменты -> Параметры) и открыть вкладку Toolbars (Панели инструментов). Этим способом можно показать или скрыть различные кнопки инструментов, а также изменить их размер.


1.3.3 Окно браузера


Окно браузера по умолчанию располагается в левой части рабочего интерфейса под стандартной панелью инструментов (рисунок 1.4).

Браузер организует представления модели в виде иерархической структуры, которая упрощает навигацию и позволяет отыскать любой элемент модели в проекте. При этом любой элемент, который разработчик добавляет в модель, сразу отображается в окне браузера. Соответственно, выбрав элемент в окне браузера, можно его визуализировать в окне диаграммы или изменить его спецификацию. Браузер позволяет также организовывать элементы модели в пакеты и перемещать элементы между различными представлениями модели. При желании окно браузера можно расположить в другом месте рабочего интерфейса либо скрыть вовсе, используя для этого пункт меню View (Вид). Можно также изменить размеры браузера, переместив мышью границу его внешней рамки.





Рисунок 1.4 – Внешний вид браузера


1.3.4 Специальная панель инструментов


Специальная панель инструментов располагается между окном браузера и окном диаграммы в средней части рабочего интерфейса. По умолчанию предлагается панель инструментов для построения диаграммы классов модели (рисунок 1.5).





Рисунок 1.5 – Внешний вид специальной панели инструментов для диаграммы классов


Расположение специальной панели инструментов можно изменять, переместив рамку панели в нужное место. Можно настраивать и состав панели, добавляя или удаляя отдельные кнопки, соответствующие тем или иным инструментам. Назначения кнопок можно узнать из всплывающих подсказок, появляющихся после задержки указателя мыши над соответствующей кнопкой.


1.3.5 Окно диаграммы


Окно диаграммы является основной рабочей областью ее интерфейса, в которой визуализируются различные представления модели проекта. По умолчанию окно диаграммы располагается в правой части рабочего интерфейса, однако его расположение и размеры также можно изменить. При разработке нового проекта, если не был использован мастер проектов, окно диаграммы представляет собой чистую область, не содержащую никаких элементов модели (рисунок 1.6).





Рисунок 1.6 – Внешний вид окна диаграмм с различными видами
представлений модели


Название диаграммы, которая располагается в данном окне, указывается в строке заголовка программы (самая верхняя строка программы) или, если окно не развернуто во весь экран, в строке заголовка окна диаграммы. Одновременно в окне диаграммы могут присутствовать несколько диаграмм, однако активной может быть только одна из них. Например, на рисунке 1.6 активной является диаграмма развертывания, хотя имеются и другие диаграммы. Переключение между диаграммами можно осуществить выбором нужного представления на стандартной панели инструментов либо через пункт меню Window (Окно). При активизации отдельного вида диаграммы изменяется внешний вид специальной панели инструментов, которая настраивается под конкретный вид диаграммы.


1.3.6 Окно документации


Окно документации по умолчанию может не присутствовать на экране. В этом случае оно может быть активизировано через пункт меню View -> Documentation (Вид->Документация), после чего появится ниже браузера (рисунок 1.7).





Рисунок 1.7 – Внешний вид окна документации


Окно документации, как следует из его названия, предназначено для документирования элементов представления модели. В него можно записывать самую различную информацию, и что важно  на русском языке. Эта информация в последующем преобразуется в комментарии и никак не влияет на логику выполнения программного кода.

В окне документации активизируется та информация, которая относится к отдельному выделенному элементу диаграммы. При этом выделить элемент можно либо в окне браузера, либо в окне диаграммы. При добавлении нового элемента на диаграмму (например, класса) автоматически генерируется документация к нему, которая является пустой (No documentation). В последующем разработчик самостоятельно вносит необходимую пояснительную информацию, которая запоминается и может быть изменена в ходе работы над проектом.

Так же, как и для других окон рабочего интерфейса, можно изменять размеры и положение окна документации.


1.3.7 Окно журнала


Окно журнала (Log) предназначено для автоматической записи различной служебной информации, образующейся в ходе работы с программой. В журнале фиксируется время и характер выполняемых разработчиком действий, таких как обновление модели, настройка меню и панелей инструментов, а также сообщений об ошибках, возникающих при генерации программного кода.





Рисунок 1.8 – Внешний вид окна журнала


Окно журнала всегда присутствует на рабочем интерфейсе в области окна диаграммы (рисунок 1.8). Однако оно может быть закрыто другими окнами с диаграммами или быть свернутым. Активизировать окно журнала можно через меню Window->Log (Окно->Журнал).
В этом случае оно изображается поверх других окон в правой области рабочего интерфейса. Полностью удалить это окно нельзя, его можно только минимизировать.

  1   2   3   4   5   6

Добавить в свой блог или на сайт

Похожие:

Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005 iconМетодические рекомендации по выполнению лабораторных работ для студентов специальностей 080801 «Прикладная информатика в экономике», 230200 «Информационные системы и технологии» Бийск
Методические рекомендации предназначены для студентов специальностей 080801, 230200 изучающих дисциплину «Алгоритмы и методы обработки...

Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005 iconМетодические указания к выполнению практических и лабораторных работ
Методические указания предназначены для студентов специальностей «Прикладная информатика (в экономике)», «Бухгалтерский учет, анализ...

Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005 iconМетодические указания по дипломному проектированию в филиалах мфпу для направления «Информационные системы» испециальностей «Информационные системы и технологии», «Прикладная информатика (в экономике)», «Прикладная информатика (в дизайне)» Под редакцией декана факультета исит денисова Д.
«Информационные системы» и специальностей «Информационные системы и технологии», «Прикладная информатика (в экономике)», «Прикладная...

Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005 iconМетодические указания по выполнению лабораторных работ №1-4 для студентов специальности 071900 «Информационные системы и технологии»
Теория информационных процессов и систем : методические указания к лабораторным работам №1–4 для студентов специальности 071900 «Информационные...

Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005 iconМетодические рекомендации по выполнению самостоятельной работы студентов специальностей 080801 «Прикладная информатика в экономике», 230201 «Информационные системы и технологии» дневной формы обучения
Методические рекомендации по выполнению самостоятельной работы студентов специальностей 080801 Прикладная информатика

Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005 iconМетодические рекомендации по изучению дисциплины для студентов специальностей 080801 «Прикладная информатика в экономике», 230201 «Информационные системы в технологии» дневной формы обучения
Методические рекомендации по изучению дисциплины для студентов специальностей 080801 «Прикладная информатика в экономике», 230201...

Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005 iconМетодические указания к выполнению лабораторных работ
Методические указания предназначены для студентов экономических специальностей при изучении дисциплин «Информационные технологии»,...

Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005 iconМетодические рекомендации по изучению дисциплины для студентов специальностей 080801 «Прикладная информатика в экономике», 230201 «Информационные системы»
Тушкина, Т. М. Теория вероятностей и математическая статистика: методические рекомендации по изучению дисциплины для студентов специальностей...

Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005 iconМетодические рекомендации по самостоятельной работе студентов специальностей 080801 «Прикладная информатика в экономике», 230201 «Информационные системы и технологии»
Издательство Алтайского государственного технического университета им. И. И. Ползунова

Методические рекомендации по выполнению лабораторных работ для студентов специальностей 351400 «Прикладная информатика (в экономике)», 071900 «Информационные системы и технологии» Бийск 2005 iconМетодические рекомендации по выполнению лабораторных работ для студентов специальностей 351100, 351300 всех форм обучения Бийск 2005 удк 668. 58
Ердакова В. П. Ассортимент и качество упаковки для косметических товаров: Методические рекомендации по выполнению лабораторных работ...


Разместите кнопку на своём сайте:
lib.convdocs.org


База данных защищена авторским правом ©lib.convdocs.org 2012
обратиться к администрации
lib.convdocs.org
Главная страница